Internet Engineering Task Force (disingkat IETF), merupakan sebuah organisasi yang menjaring banyak pihak (baik itu individual ataupun organisasional) yang tertarik dalam pengembangan jaringan komputer dan Internet. Organisasi ini diatur oleh IESG (Internet Engineering Steering Group), dan diberi tugas untuk mempelajari masalah-masalah teknik yang terjadi dalam jaringan komputer dan Internet, dan kemudian mengusulkan solusi dari masalah tersebut kepada IAB (Internet Architecture Board). Pekerjaan IETF dilakukan oleh banyak kelompok kerja (disebut sebagai Working Groups) yang berkonsentrasi di satu bagian topik saja, seperti halnya keamanan, routing, dan lainnya. IETF merupakan pihak yang mempublikasikan spesifikasi yang membuat standar protokol TCP/IP.
Minggu, 06 November 2011
Sistem Penamaan Domain (DNS)
Sistem Penamaan Domain ; SNR (bahasa Inggris: (Domain Name System; DNS) adalah sebuah sistem yang menyimpan informasi tentang nama host maupun nama domain dalam bentuk basis data tersebar (distributed database) di dalam jaringan komputer, misalkan: Internet. DNS menyediakan alamat IP untuk setiap nama host dan mendata setiap server transmisi surat (mail exchange server) yang menerima surel (email) untuk setiap domain.
DNS menyediakan servis yang cukup penting untuk Internet, bilamana perangkat keras komputer dan jaringan bekerja dengan alamat IP untuk mengerjakan tugas seperti pengalamatan dan penjaluran (routing), manusia pada umumnya lebih memilih untuk menggunakan nama host dan nama domain, contohnya adalah penunjukan sumber universal (URL) dan alamat surel. Analogi yang umum digunakan untuk menjelaskan fungsinya adalah DNS bisa dianggap seperti buku telepon internet dimana saat pengguna mengetikkan www.contoh.com di peramban web maka pengguna akan diarahkan ke alamat IP 192.0.32.10 (IPv4) dan 2620:0:2d0:200:10 (IPv6).
Sejarah Singkat DNS
Penggunaan nama sebagai pengabstraksi alamat mesin di sebuah jaringan komputer yang lebih dikenal oleh manusia mengalahkan TCP/IP, dan kembali ke zaman ARPAnet. Dahulu, setiap komputer di jaringan komputer menggunakan file HOSTS.TXT dari SRI (sekarang SIR International), yang memetakan sebuah alamat ke sebuah nama (secara teknis, file ini masih ada - sebagian besar sistem operasi modern menggunakannya baik secara baku maupun melalui konfigurasi, dapat melihat Hosts file untuk menyamakan sebuah nama hostmenjadi sebuah alamat IP sebelum melakukan pencarian via DNS). Namun, sistem tersebut diatas mewarisi beberapa keterbatasan yang mencolok dari sisi prasyarat, setiap saat sebuah alamat komputer berubah, setiap sistem yang hendak berhubungan dengan komputer tersebut harus melakukan update terhadap file Hosts.
Dengan berkembangnya jaringan komputer, membutuhkan sistem yang bisa dikembangkan: sebuah sistem yang bisa mengganti alamat host hanya di satu tempat, host lain akan mempelajari perubaha tersebut secara dinamis. Inilah DNS.
Paul Mockapetris menemukan DNS di tahun 1983; spesifikasi asli muncul di RFC 882 dan 883. Tahun 1987, penerbitan RFC 1034 dan RFC 1035 membuat update terhadap spesifikasi DNS. Hal ini membuat RFC 882 dan RFC 883 tidak berlaku lagi. Beberapa RFC terkini telah memproposikan beberapa tambahan dari protokol inti DNS.
Alamat IP
Internet Protocol Address atau sering disingkat IP
adalah deretan angka biner antar 32-bit sampai 128-bit yang dipakai sebagai alamat identifikasi untuk tiap komputer host dalam jaringan Internet. Panjang dari angka ini adalah 32-bit (untuk IPv4 atau IP versi 4), dan 128-bit (untuk IPv6 atau IP versi 6) yang menunjukkan alamat dari komputer tersebut pada jaringan Internet berbasis TCP/IP.
Sistem pengalamatan IP ini terbagi menjadi dua, yakni:
● IP versi 4 (IPv4)
● IP versi 6 (IPv6)
Perbandingan Alamat IPv6 dan IPv4
Tabel berikut menjelaskan perbandingan karakteristik antara alamat IP versi 4 dan alamat IP versi 6.
Kriteria | ||
Panjang alamat | 32 bit | 128 bit |
Jumlah total host (teoritis) | 232=±4 miliar host | 2128 |
Menggunakan kelas alamat | Ya, kelas A, B, C, D, dan E. Belakangan tidak digunakan lagi, mengingat telah tidak relevan dengan perkembangan jaringan Internet yang pesat. | Tidak |
Alamat multicast | Alamat multicast | Alamat multicast IPv6, yaitu FF00:/8 |
Alamat broadcast | Ada | Tidak ada |
Alamat yang belum ditentukan | 0.0.0.0+ | :: |
Alamat loopback | 127.0.0.1 | ::1 |
Alamat IP publik | Alamat IP publik IPv4, yang ditetapkan oleh otoritas Internet (IANA) | Alamat IPv6 unicast global |
Alamat IP pribadi | Alamat IP pribadi IPv4, yang ditetapkan oleh otoritas Internet | Alamat IPv6 unicast site-local(FEC0::/48) |
Konfigurasi alamat otomatis | Ya (APIPA) | Alamat IPv6 unicast link-local(FE80::/64) |
Representasi tekstual | Dotted decimal format notation | Colon hexadecimal format notation |
Fungsi Prefiks | Subnet mask atau panjang prefiks | Panjang prefiks |
Resolusi alamat DNS | A Resource Record (Single A) | AAAA Resource Record (Quad A) |
Sumber : InfoKomputer.com
Transmission Control Protocol
Transmission Control Protocol (TCP) adalah suatu protokol yang berada di lapisan transpor (baik itu dalam tujuh lapis model referensi OSI atau model DARPA) yang berorientasi sambungan (connection-oriented) dan dapat diandalkan (reliable). TCP dispesifikasikan dalam RFC 793.
Sejarah
Saat Vint Cerf dan Bob Kahn pertama menulis spesifikasi atas protokol ini tahun 1973, internet masih merupakan media yang dilarang untuk keperluan komersil. Di bulan May 1974, IEEE mempublikasikan makalah berjudul "Protokol sebagai paket interkoneksi jaringan." Sebagai penulis makalah tersebut, Cerf dan Kahn menjabarkan sebuah protokol interkoneksi untuk berbagi layanan dengan memanfaatkan pertukaran-paket antara node jaringan yang terhubung. Komponen pengontrol utama atas model ini disebut sebagai "Program pengontrol transmisi" yang menggabungkan baik tautan koneksi teriorientasi dan layanan datagram antar host. Program pengontrol transmisi monolitik ini kemudian dipecah ke dalam arsitektur modular yang terdiri atas Protokol pengontrol transmisi pada lapisan koneksi terorientasi dan Protokol internet pada lapisan datagram. Model ini lah yang kemudian dikenal dengan istilah TCP/IP, meski secara formal istilah yang digunakan adalah Paket protokol internet.
Kamis, 03 November 2011
Google Chrome
Google Chrome
Google Chrome adalah sebuah peramban web sumber terbuka yang dikembangkan oleh Google dengan menggunakan mesin rendering WebKit. Proyek sumber terbukanya sendiri dinamakan Chromium.
Versi beta untuk Microsoft Windows diluncurkan pada 2 September 2008 dalam 50 bahasa. Versi Mac OS X dan Linux sudah dirilis.
Pengembang
|
Google Inc.
|
Rilis pertama
|
September 2, 2008; 3 tahun yang lalu
|
Bahasa pemrograman
|
C++, Assembly, Python, JavaScript
|
Sistem operasi
|
Linux, Mac OS X (ver.10.5 dan versi selanjutnya), Microsoft Windows, Windows XP SP2, Windows Vista, dan Windows 7
|
Bahasa
|
50 bahasa
|
Status pengembangan
|
Aktif
|
Jenis
|
Peramban web
|
Lisensi
|
Google Chrome Terms of Service, WebKit: BSD/LGPL, V8: BSD
|
Situs web
|
google.com/chrome
|
Langganan:
Postingan (Atom)